All new Android smartphones – high and low end – must run KitKit or Google will not approve the handset, according to a leaked memo.

    




View source website